KTM 790 Duke Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
So im about to purchase yoshimura turn signals for the rear of my bike, i plan to buy some for the front when my budget allows it. Do i need a resistor kit to only run LED's on the rear? ive read mixed things on it and it seems to depend on the signals.

I read in one of the forums on here that somebody was successful when they ran yoshimura turn signals on both the front and rear with the sicass 690 resistor kit and didnt get any error codes, thats what i am aiming for in the long run. Right now i just want to get my tail tidy on and not melt my US spec indicators. Hoping to not waste money on unnecessary parts at the moment. If i can get away with just running the $30 resistor kit on the rear that would be fine but a $7 adapter would be even better. any help is appreciated!

Jenneka
 

·
Registered
Joined
·
106 Posts
So im about to purchase yoshimura turn signals for the rear of my bike, i plan to buy some for the front when my budget allows it. Do i need a resistor kit to only run LED's on the rear? ive read mixed things on it and it seems to depend on the signals.

I read in one of the forums on here that somebody was successful when they ran yoshimura turn signals on both the front and rear with the sicass 690 resistor kit and didnt get any error codes, thats what i am aiming for in the long run. Right now i just want to get my tail tidy on and not melt my US spec indicators. Hoping to not waste money on unnecessary parts at the moment. If i can get away with just running the $30 resistor kit on the rear that would be fine but a $7 adapter would be even better. any help is appreciated!

Jenneka
[/QUOT
I think it will depend on which led indicator youve got, as to how much resistance.
I changed from Euro OEM led to Chinese, and Im getting the dash alert- indicator failure, indicators are flashing normal though.
I ended up adding some leds inside the housing which fixed it, but on the US model youd be looking at getting some ceramic 50w wire wound resistors from the motorbike shop.
 

·
Registered
Joined
·
22 Posts
Motosupial - what do you mean by "adding some leds inside the housing"? So no more error codes, and all that done without needing any resistors?
 

·
Registered
Joined
·
439 Posts
Yoshimura sells a diode wire to go with the leds to fix the dash error. 10.95


There is a video on the led page explaining about what the diode does.

 

·
Registered
Joined
·
439 Posts
Yoshimura sells a diode wire to go with the leds to fix the dash error. 10.95


There is a video on the led page explaining about what the diode does.

I re-watched the video. They also supply a relay. So in retrospect. I'm not sure if the dash warning light comes on or not. Heavy Sigh
 

·
Registered
2020 790 Duke, 2006 SV 650, 2008 Hot rodded KLR, 1991 Honda Hawk NT 650
Joined
·
156 Posts
What I've read is that if you only do the rear signals no other mod is required. Once you also change the front units then you'll need to add resistors.
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #8 ·
So to follow up on this i did just install the rear signals without resistors and they work great but I get the error on the dash everytime I turn them on, which is fine for now. I should just buy some resistors and see if it fixes it but ultimately I want to replace the ugly front signals too. I didnt think the yoshimura diodes worked with our bikes, but I can't remember if that's just because it didn't show it under fitment or if I actually verified that because this was almost a year ago lol
 

·
Registered
Joined
·
439 Posts
So to follow up on this i did just install the rear signals without resistors and they work great but I get the error on the dash everytime I turn them on, which is fine for now. I should just buy some resistors and see if it fixes it but ultimately I want to replace the ugly front signals too. I didnt think the yoshimura diodes worked with our bikes, but I can't remember if that's just because it didn't show it under fitment or if I actually verified that because this was almost a year ago lol
I installed led turn signals on the front first with resistors on both. They work perfectly and with no dash error. I just did the tail tidy and rear leds see Yoshimura tail tidy install post.
 
1 - 9 of 9 Posts
Top