KTM 790 Duke Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
64 Posts
Discussion Starter · #1 ·
On my 890R the quickshifter has a tendency to miss the gear and slip into neutral if the shifter is not pulled decisevely when upshifting. I'ts a problem because then the engine loses revs and in the 2 instances in which it happened when I could not bring the bike to a halt this causes a loud bang when the clutch is re-engaged in gear.

This happend twice so far:

1) on the motorway at 60ish mph, it went into neutral and then (by itself), re engaged in 5th gear (it was a 5th to 6th upshift), very loud bang.
2) during an overtake, 2 to 3rd, after it happened I pulled the clutch, re engaged the second gear, again loud bang.

Now I have see at least one other owner with the same issue on another forum but would like to know if this is actually happening on most bikes or if there is something wrong with mine. Esp. in the context that after the last time it happened, I feel like the bike is harder to shift and maybe it caused some transmission damage.

The bike is due to be serviced in 3 months and I'm going to bring it up, asking maybe them to check thoroughly the oil filters for metal due to the above accidents, etc. But they'll probably dismiss it and tell me to shift harder. Note that I've tried an mt09 and under no circumstances something like this would happen on it (considerably better QS imho).

Thanks in advance
 

·
Registered
Joined
·
155 Posts
this happens to my bike occasionally as well 5-6, however im pretty sure its not me lazy shifting, cuz mine also goes to N from 1-2 and im always trying to figure it out and paying extra attention, however my issues tie into the ktm powerparts rearsets, i may have had very few mis shifts with stock rearsets, but after the powerparts, i get mis-shifts at least a few times a week.

this happens alot more often when bike is warm, like it wont do it on my commute until 10+ mins ride in and getting off freeway at first light and needing to go 1-2
 

·
Registered
Joined
·
272 Posts
Yes, this has happened a few times on my 890r. And I hardly ever use the QS. I think the problem is in the amount of movement required between gearshifts as compared to the time the ignition is cut for.
I will adjust the gear lever down a little to try help the situation but would love to try a shorter throw gear arm.
 

·
Registered
Joined
·
363 Posts
I had my QS recalibrated and my 2nd-3rd false neautrals have disappeared. I had disabled my QS near end of last season it worked so poorly. So far this year no problems!
 

·
Registered
Joined
·
155 Posts
Lucky I asked to get my quickshifter recalibrated when I still had warranty.

Dealer basically says nope, all we gonna do is plug in and read codes and if there aren't any and you want to recalibrate the qs then I get to pay for all the time to do that and plugging in ECU etc, I explained I had misshifts 1-2 and 5-6 occasionally, they said sure but no codes = nothing wrong and customer needs to pay for recalibration even under warranty. I explained other ppl posted up having issues and got qs recalibrated under warranty - they said good for them. But not how we gonna do it/charge time etc
 
1 - 9 of 9 Posts
Top