KTM 790 Duke Forum banner

21 - 35 of 35 Posts

·
Premium Member
Joined
·
389 Posts
Yeah, I wondered about ambient temperature too. Obviously here in Vancouver, we're heading the other way (into fall) and it was slightly cooler recently, but certainly not a radical drop in temps - just a few degrees.
Mark,
As mentioned, I've been collecting some data on cold starts which you can see on the spreadsheet. After continuous days of "hunting" and stalling on the first start, it has now stopped! The reasons why are inconclusive. I don't think it was ambient temperature related. All I did differently after waiting for the fuel system to pressurize was to fully open and close the throttle several times before hitting the starter and haven't had the problem since. Any conclusions would be speculative....... sticking injector fixing itself, throttle position sensor reset? Who knows but I'm glad that the bike is totally back to normal.
5398
 

·
Registered
Joined
·
143 Posts
After continuous days of "hunting" and stalling on the first start, it has now stopped!
Hi Geoff, thanks for the follow up. I'd had the exact same results - after a few consecutive days of hunting on start up, the issue just went away, and knock-on-wood it'll stay that way!
 

·
Registered
Joined
·
14 Posts
Mine has been doing it intermittently from new. ECU update at first service did not solve it. No heads or reason about it, warm or cool day, if the engine is cold it may (or not) do it. Just hit the starter again and carry on with my life...
 

·
Registered
Joined
·
77 Posts
Mark,
As mentioned, I've been collecting some data on cold starts which you can see on the spreadsheet. After continuous days of "hunting" and stalling on the first start, it has now stopped! The reasons why are inconclusive. I don't think it was ambient temperature related. All I did differently after waiting for the fuel system to pressurize was to fully open and close the throttle several times before hitting the starter and haven't had the problem since. Any conclusions would be speculative....... sticking injector fixing itself, throttle position sensor reset? Who knows but I'm glad that the bike is totally back to normal. View attachment 5398
Yeah l use that exact method and no problems since (but l might speak too early)
 

·
Registered
Joined
·
3 Posts
So my 2018 has had the whole reving up & also stalling on cold start problem. Dealer could not fault the bike, not throwing any codes.

Yesterday I installed a PCV (Rottweiler Performance Stock Tune), and it is like a different bike. Starts first go, straight to a normal idle and sits there warming up. My O2 sensors are now completely disconnected.

This might give someone a push in the right direction into finding the cause. I have not found what caused my cold start issues, but I found my solution.
 

·
Registered
Joined
·
33 Posts
I'm sure this problem is a combination stock tune / O2 sensor "problem". I say problem lightly, because in my experience it has never been really a problem past it shuts off once in a while. Really makes me think people forget these are really a first generation bikes, and forget the days of carburetors and chokes. If starting once and stalling is the worst issue we have, I think we will all be fine. ..
 

·
Registered
Joined
·
170 Posts
Mine did that in winter. I just thought it was an overly rich mixture, it was ok after a few starts so I didnt bother. Maybe its KTM policy to rev the crap out of a cold engine where the bearing oil films have diminished - wear the engine out quicker..
 

·
Registered
Joined
·
25 Posts
Yesterday I installed a PCV (Rottweiler Performance Stock Tune), and it is like a different bike. Starts first go, straight to a normal idle and sits there warming up. My O2 sensors are now completely disconnected.
Probably too early for this question, but have you noticed better or worse gas mileage with it? Is the throttle any different?
 

·
Premium Member
Joined
·
389 Posts
Mine has been doing it intermittently from new. ECU update at first service did not solve it. No heads or reason about it, warm or cool day, if the engine is cold it may (or not) do it. Just hit the starter again and carry on with my life...
After a prolonged period of normality, mine has done it twice from cold start in the last week - completely random. When it was doing it pretty much every time from a cold start, turning the ignition on and fully opening the throttle without hitting the starter, then closing it seemed to guarantee a cold start . No big deal and not actively looking for a solution.
 

·
Registered
Joined
·
3 Posts
Probably too early for this question, but have you noticed better or worse gas mileage with it? Is the throttle any different?
Not sure on fuel economy yet, will know after a week of commuting on it. As for throttle, it is like a different bike. Less temperamental at low speed, and mid-range acceleration has improved.

More cold starts aswell, and still no issues. Problem is completely resolved with my PCV.
 

·
Registered
Joined
·
25 Posts
Not sure on fuel economy yet, will know after a week of commuting on it. As for throttle, it is like a different bike. Less temperamental at low speed, and mid-range acceleration has improved.
That's pretty cool about the throttle. I mean, my gas economy can't get much worse. Getting an even 100mpg.
 

·
Registered
Joined
·
100 Posts
Oh boy, the dealer service people roll their eyes when I ask about updates/versions .... "if it runs fine, leave it alone"
Until your dealer hooks the bike up to the KTM diag system, they have no idea what updates are even avail for your bike. The different subsystems are also discrete updates/versions.
 

·
Registered
Joined
·
100 Posts
Which is crazy. Also, lazy in my opinion.
I guess...it's part of the sched maint if you have it done at a dealer. My dealer will throw my bike on the system for free if I leave it for them to do when they aren't busy or I can pay a nominal labor if I want to sched an appointment & wait. It's never really been an issue for me over a couple KTMs.
 
21 - 35 of 35 Posts
Top