KTM 790 Duke Forum banner

201 - 207 of 207 Posts

·
Registered
Joined
·
105 Posts
Hey folks I’ll add my experience. I installed Yoshimura rear signals on my bike and ordered Amazon 4x 10w resistors. They failed to work on install so I did some homework. Using the attached readings from my multimeter 12.6v and 0.72amp draw from signal. I determined that the stock signal has about 17Ohms of resistance. So I wired 2 of the 10w 10 Ohm resistors in series to each other and then wired them in parallel to the LED signal so I’d have a 20w 20 Ohms per signal. The dash indicator flashes slowly, and no warning message now.
6802
6803
 

·
Registered
Joined
·
4 Posts
So I installed the MNNTHBX rear Corsa S signals successfully using the R&G 21.5 Ohm resistors. No signal errors.

This week I installed the Corsa L's in the front using the cable adapters . These are the RIZOMA with daylight running light. I spliced them into the daylight rubbing light harness (green with red wire) which got the DRL to work.

Issue is that the indicator error is now popping up on the screen. I used the rizoma resistors that came with the lights in both recommended configurations but neither worked.

Does anyone know if the R&G 21.5 resistors will fix the front as well?
 

·
Registered
Joined
·
380 Posts
So I installed the MNNTHBX rear Corsa S signals successfully using the R&G 21.5 Ohm resistors. No signal errors.

This week I installed the Corsa L's in the front using the cable adapters . These are the RIZOMA with daylight running light. I spliced them into the daylight rubbing light harness (green with red wire) which got the DRL to work.

Issue is that the indicator error is now popping up on the screen. I used the rizoma resistors that came with the lights in both recommended configurations but neither worked.

Does anyone know if the R&G 21.5 resistors will fix the front as well?
I used the R&G 9.8 ohm resistors on my Yoshimura turn signals front and rear with no issues.
 

·
Registered
Joined
·
8 Posts
Went to install my Morimoto indicators and hit a couple snags.
They are too small for any of the stock holes to mount , so I’m going to see if I can 3D print a mounting plate at work.
Next , yes they are bright .
They do have the slow flash rate without resistors , but I do get the indicator warning on the display.
I’m goin to start with the dealership switching the ECU to LED mode before installing resistors.
6875
FDECAD02-8482-45A1-B4B9-454421A41C75.jpeg
 

·
Registered
Joined
·
22 Posts
Went to install my Morimoto indicators and hit a couple snags.
They are too small for any of the stock holes to mount , so I’m going to see if I can 3D print a mounting plate at work.
Next , yes they are bright .
They do have the slow flash rate without resistors , but I do get the indicator warning on the display.
I’m goin to start with the dealership switching the ECU to LED mode before installing resistors. View attachment 6875 View attachment 6875
I had to 3D print adaptors to fit the turn signals i bought. They are nice and flush now and i have been running them for about 6+8 months.
6905
 
201 - 207 of 207 Posts
Top