KTM 790 Duke Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 · (Edited)
Maybe my bike is a unicorn or something but I wanted to share with you guys my experience quick.

After doing some research I bought myself a cheap set of ebay lights and resistors that I figured i'd need for the installation. I decided to try it really quick without them just in case and I am getting perfect blink rate and no warning on the dash etc.

My duke 790 is a 2019 that i bought a few weeks ago new. The dealer did do a firmware update before I got it but I'm not sure if that has anything to do with it.

Here's a link to exactly what I bought. they look really good for $17.
 

·
Registered
Joined
·
512 Posts
Maybe my bike is a unicorn or something but I wanted to share with you guys my experience quick.

After doing some research I bought myself a cheap set of ebay lights and resistors that I figured i'd need for the installation. I decided to try it really quick without them just in case and I am getting perfect blink rate and no warning on the dash etc.

My duke 790 is a 2019 that i bought a few weeks ago new. The dealer did do a firmware update before I got it but I'm not sure if that has anything to do with it.

Here's a link to exactly what I bought. they look really good for $17.
Welcome to the club! The links missing... and I'm very curious :p
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top