KTM 790 Duke Forum banner
1 - 20 of 21 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter · #1 ·
Looking for some help. I’ve installed the My Ride Connectivity box and had it turned on with the dealer.
The bike will connect to my iPhone then my Sena headset is connected to iPhone. I see the Bluetooth symbol on the bike screen and it shows connected on my phone as well as the headset.
When I go to Audio Device on the screen it says to connect phone or get into range w Bluetooth can anyone help with this?
Another thing is if I’m called it shows on the screen but I cannot hear it on the headset unless I press connect to Sena headset.
 

·
Registered
Joined
·
16 Posts
Discussion Starter · #5 ·
Looking for some help. I’ve installed the My Ride Connectivity box and had it turned on with the dealer.
The bike will connect to my iPhone then my Sena headset is connected to iPhone. I see the Bluetooth symbol on the bike screen and it shows connected on my phone as well as the headset.
When I go to Audio Device on the screen it says to connect phone or get into range w Bluetooth can anyone help with this?
Another thing is if I’m called it shows on the screen but I cannot hear it on the headset unless I press connect to Sena headset.
 

·
Registered
Joined
·
16 Posts
Discussion Starter · #6 ·
I can connect the bike to the Sena headset and I can connect to my Iphone.
I cannot get the bikes controls to control any stop/start functions in music on my phone.
If someone calls I can answer it with the bike but I cannot control the volume.
If I press play on the iPhone for music it appears to be playing but not through the headset nor do I hear anything from my iPhone.
 

·
Registered
Joined
·
15 Posts
I can connect the bike to the Sena headset and I can connect to my Iphone.
I cannot get the bikes controls to control any stop/start functions in music on my phone.
If someone calls I can answer it with the bike but I cannot control the volume.
If I press play on the iPhone for music it appears to be playing but not through the headset nor do I hear anything from my iPhone.
 

·
Registered
Joined
·
1,956 Posts
Turn WiFi OFF, I find (professionally) that Wifi and BT often use the same antenna circuits. It's how I got the car BT to sync. Mine's a work phone with a monster 4G data limit so why use home WiFi.
 

·
Registered
Joined
·
16 Posts
Discussion Starter · #9 ·
Turn WiFi OFF, I find (professionally) that Wifi and BT often use the same antenna circuits. It's how I got the car BT to sync. Mine's a work phone with a monster 4G data limit so why use home WiFi.
I will try that.
I’m trying to pair in my garage and WiFi router is just in the next room.
Thanks I’ll keep ya posted
 

·
Registered
Joined
·
16 Posts
Discussion Starter · #10 ·
Ok the issue was my home WiFi. It was messing up the connections.
Heres what worked for me.
1) disconnect WiFi from phone
2) pair phone to bike
3) turn on gps pairing on the headset
4) pair headset to bike (it took 30 sec to do)
5) paired and ready!
 

·
Registered
Joined
·
15 Posts
Do you have any volume control that works from the handlebar or do you have to adjust via your headset like mine ?
 

·
Registered
Joined
·
47 Posts
Do you have any volume control that works from the handlebar or do you have to adjust via your headset like mine ?
If works like on the 390, which seems from the dash picture,
  1. quick press Up/Down you change music track
  2. Long press Up or Down and the Volume goes up/down
 

·
Registered
Joined
·
47 Posts
must differ with KTM models. No volume control at all on the 790
again with MyRide option, once your phone is paired, the switches on the left of the handlebars control your music.
Right = play / pause
Up/Down = Change music or Volume Up/down if long pressed
 

·
Registered
Joined
·
15 Posts
Again no handlebar volume control works on my 790. Tried 5 different phones with 3 different headsets. All other functions are OK
 

·
Registered
Joined
·
16 Posts
Discussion Starter · #17 ·
I will check on the volume issue later today.
I wonder why the speed reads in KM instead of MPH on the main menu screen.
How do we change that?
 

·
Registered
Joined
·
47 Posts
Again no handlebar volume control works on my 790. Tried 5 different phones with 3 different headsets. All other functions are OK
oh understand your comment now.

Seems strange as the 790 dash picture above shows the two functions linked like on the 390.
You have to keep pressing for some time before volume changes...guess you tried that.
Sorry can't help then
 

·
Registered
Joined
·
15 Posts
All good.. have taken it to a dealer here and they have connected the diagnostic tool to get some info from the ECU to send to KTM. Haven't heard back from them yet as to whether it can be sorted
 

·
Registered
Joined
·
16 Posts
Discussion Starter · #20 ·
All good.. have taken it to a dealer here and they have connected the diagnostic tool to get some info from the ECU to send to KTM. Haven't heard back from them yet as to whether it can be sorted
Well I cannot adjust the volume with the bikes controls. Just the stop/pause and fast forward/rewind.
I wonder if the 790 Duke adventurers software would work on the regular Duke. Im told it has the NAV. Not sure if the volume works with it.
 
1 - 20 of 21 Posts
Top