KTM 790 Duke Forum banner

1 - 20 of 127 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Immobilation Alert

Question about voltage limits...
After a very long wait, I picked up my 790 last weekend with 5 miles on the Odo. Rode tested the bike for another 3 miles while at the dealership — no issues except I wanted to ride more! Trailered home and installed a Battery tender SAE lead directly to the battery (has 15amp fuse between battery and lead). Trickel charged battery and went green within 5 minutes (yah!)
When weather finally cleared I set out for my REAL maiden voyage and received an Immobizer Alert not but 1000 ft from my driveway. Engine shut down. Could not restart.
Scrolling through the computer, lots of errors/codes were displayed (MTC and ABS Cornering). After a rest, the bike started but still threw errors including ABS Failure.
KTM Tech ran diagnostic this morning and reports no current errors and show one historical battery error.
1. Has anyone installed battery tender leads? Issues? Maybe I need a 10amp fuse on the BT Lead?
2. Does anyone have any idea of stator capacity/ amperage allowed? My Tech or Advisor doesn’t know.
3. Does anyone run heated gear on their 790?

Thanks in advance!
 

Attachments

·
Registered
Joined
·
197 Posts
My electrical and technical knowledge is not able to answer this incident.
I have used a Tecmate Optimate 4 battery charger tester, and have had no problems.
I also have Gerbing gloves powered straight from the battery, again no problems.
Just make sure that everything is connected well and tightened.
 

·
Wish You Were Here
Joined
·
619 Posts
Question about voltage limits...
After a very long wait, I picked up my 790 last weekend with 5 miles on the Odo. Rode tested the bike for another 3 miles while at the dealership — no issues except I wanted to ride more! Trailered home and installed a Battery tender SAE lead directly to the battery (has 15amp fuse between battery and lead). Trickel charged battery and went green within 5 minutes (yah!)
When weather finally cleared I set out for my REAL maiden voyage and received an Immobizer Alert not but 1000 ft from my driveway. Engine shut down. Could not restart.
Scrolling through the computer, lots of errors/codes were displayed (MTC and ABS Cornering). After a rest, the bike started but still threw errors including ABS Failure.
KTM Tech ran diagnostic this morning and reports no current errors and show one historical battery error.
1. Has anyone installed battery tender leads? Issues? Maybe I need a 10amp fuse on the BT Lead?
2. Does anyone have any idea of stator capacity/ amperage allowed? My Tech or Advisor doesn’t know.
3. Does anyone run heated gear on their 790?

Thanks in advance!
my battery tender lead has a 5amp fuse
I run heated grips but not gloves or clothing
if you use the aux power supply this is fused

whats the current requirement for your heated gear?


how did you wire them up?
 

·
Registered
Joined
·
5 Posts
Started flashing immobilizer failure after 15 minutes of riding. Pulled off to check the bike and after shutdown the bike would crank, but not start. Anyone else have this issue?
 

·
Registered
Joined
·
5 Posts
We are having the same issue. Mine did it after 15 min of riding and 41 miles. Bike would run, but would not restart after cycling key off. Did start after 30 min of trying. What is your doing now?
 

·
Registered
Joined
·
4 Posts
Discussion Starter #9
I disconnected the SAE plug that I connected directly to the battery. I let it reset for 24 hours plus - rode 45 miles this afternoon with no issues.

I'm thinking the Euro map is different from the US map? I'm assuming you have a US version?

I'm looking for a KTM accessory plug for ACC 1 that has an SAE on the other end- can only find the heated grips (that will go into ACC 2) and an accessory plug with a USB on the other end. The Manual states to use aligator clips for battery trickle charge - that's a pain in the arse.
 

·
Registered
Joined
·
55 Posts
I disconnected the SAE plug that I connected directly to the battery. I let it reset for 24 hours plus - rode 45 miles this afternoon with no issues.

I'm thinking the Euro map is different from the US map? I'm assuming you have a US version?

I'm looking for a KTM accessory plug for ACC 1 that has an SAE on the other end- can only find the heated grips (that will go into ACC 2) and an accessory plug with a USB on the other end. The Manual states to use aligator clips for battery trickle charge - that's a pain in the arse.
Shouldn't think charging clips would matter really, as long as nothing is backwards :) Could be battery is too small for what you're pulling?
 

·
Wish You Were Here
Joined
·
619 Posts
I disconnected the SAE plug that I connected directly to the battery. I let it reset for 24 hours plus - rode 45 miles this afternoon with no issues.

I'm thinking the Euro map is different from the US map? I'm assuming you have a US version?

I'm looking for a KTM accessory plug for ACC 1 that has an SAE on the other end- can only find the heated grips (that will go into ACC 2) and an accessory plug with a USB on the other end. The Manual states to use aligator clips for battery trickle charge - that's a pain in the arse.
ACC 1 and ACC2
ONE IS ON ALL THE TIME THE OTHER WITH IGNITION
 

·
Registered
Joined
·
4 Posts
Discussion Starter #13
Update - KTM Advisor from dealership let me know that another Duke from the Dealership has surfaced with this issue. It's become a known issue with the Immobilizer Alert. They are working on a fix.
 

·
Registered
Joined
·
5 Posts
Could be that the dealer didn't turn off demo mode when they sold it to you. They do this so someone can't just ride off and steal the bikes on the test rides. I learned all about it from my dealer.
 

·
Registered
Joined
·
11 Posts
Yes! After I rode it home two miles from taking delivery I got errors for abs, tc, and immobilizer. It has been intermittent and the bike is at the dealer for the second time as they try to figure it out.
 

·
Registered
Joined
·
11 Posts
Yes! After I rode it home two miles from taking delivery I got errors for abs, tc, and immobilizer. It has been intermittent and the bike is at the dealer for the second time as they try to figure it out.
 

·
Registered
Joined
·
5 Posts
The dealer is saying this has affected a large number of US 790's. The initial fix or changing the immobilizer and keys did not work. They are working on a solution, but currently do not know why the bikes are shutting down like this.
 

·
Registered
Joined
·
11 Posts
Yes! After I rode it home two miles from taking delivery I got errors for abs, tc, and immobilizer. It has been intermittent and the bike is at the dealer for the second time as they try to figure it out.
Following up on my issue, they replaced the keys and immobilizer. I got the bike back yesterday after a week of waiting for diagnosis and parts to arrive. So far, I have not run into the issue after a number of short trips.
 

·
Registered
Joined
·
7 Posts
I am following this thread. Just bought a 790. Drove it to the court house for registration. On the way back home I got ABS & MTC failure, Immobilizer Failure, and Key Failure. I was able to restart the bike after a few minutes on the first try. I did notice that the mph disappeared after the failures were acknowledged. The bike has less that 20 miles on it.
 
1 - 20 of 127 Posts
Top