KTM 790 Duke Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
44 Posts
Discussion Starter #1
Bought the bike new in Birmingham last October and the gear indicator only showed neutral. Didn't ride it over winter as busy with other bikes. Took it back to Birmingham for first service three weeks ago and they diagnosed a gear shift sensor but didn't have one. Took the bike to Swindon today (more local) for it fixing under warranty but it's not the sensor. Fun and games trying to get the two dealers to decide how to deal with that one..
Bike now being picked up tomorrow by DMC Moto in Birmingham 70 miles away and will hopefully get it back to go to Spain a week tomorrow. Modern electronics eh - what a pain this has been chasing two dealers to fix it..Hey ho
 

·
Registered
Joined
·
44 Posts
Discussion Starter #4
DMC Birmingham picked the bike up, fixed it and returned it last week.Just in the boat to Spain now 😀
 

·
Registered
Joined
·
106 Posts
I had a similar with mine - in addition to the shift indicator not working the quick shifter was very jerky and false neutrals were very prevalent - At the 600 service all were resolved perfectly with a software update on the KTM system - I was impressed at how much those three items got resolved - initially the tech told me it was either the sensor or the instrument cluster - ( he admittedly was guessing as he'd not done any service on the 790 at that point - bear in mind they only arrived in the US in early Nov of 18) - turned out it was software as mentioned above

I had no idea how great a quick shifter is on a bike as I'd never had one - of course all of that was done under warranty - the bike at 5000 miles runs great - no complaints at all
 
1 - 7 of 7 Posts
Top