KTM 790 Duke Forum banner
1 - 12 of 12 Posts

·
Registered
Joined
·
34 Posts
Discussion Starter · #1 ·
Hi Everyone:

2020 790. It's been sitting for a month. Went to turn it on today and the engine screamed at me - revving on its own, idled and revved high again about 5x before i noticed smoke from the front and the bike shut itself off. Turned it back on, ran fine. Let it run to temp and noticed coolant dripping from the hose (see pic). Anyone have this issue?

Bike is under warranty. I just put on a slip on exhaust 2 months ago. Will the dealers be sticklers on this and say the bike is modified therefore the warranty is void or is that just for cars? Never done warranty service on a bike.

Thanks in advance for any help
 

Attachments

·
Registered
Joined
·
32 Posts
I had the thermostat housing crack which my dealer replaced. I have a Yosh slip-on and my dealer didn’t say anything about it. The dealer has done all the service both before and after I installed the exhaust. BTW I replaced the coolant hoses with Samco hoses they are much better than the stock hoses.
Cheers.
 

·
Registered
Joined
·
34 Posts
Discussion Starter · #3 ·
I had the thermostat housing crack which my dealer replaced. I have a Yosh slip-on and my dealer didn’t say anything about it. The dealer has done all the service both before and after I installed the exhaust. BTW I replaced the coolant hoses with Samco hoses they are much better than the stock hoses.
Cheers.
Wow, thank you for the quick response and good news!

That sounds great..I'll call them up on Friday!
 

·
Registered
Joined
·
91 Posts
Hi Everyone:

2020 790. It's been sitting for a month. Went to turn it on today and the engine screamed at me - revving on its own, idled and revved high again about 5x before i noticed smoke from the front and the bike shut itself off. Turned it back on, ran fine. Let it run to temp and noticed coolant dripping from the hose (see pic). Anyone have this issue?

Bike is under warranty. I just put on a slip on exhaust 2 months ago. Will the dealers be sticklers on this and say the bike is modified therefore the warranty is void or is that just for cars? Never done warranty service on a bike.

Thanks in advance for any help
Hi Had

Revving on startup affects many 790Ds

No known cure but a way to prevent it posted somewhere on here. Turn ignition on, wait fuel pump to stop spinning up then give two squirts of throttle. Hit start and should be okay. My 2018 would overrev maybe one in ten starts. Hasn’t happened once since using this method 👍

Cheers
 

·
Registered
Joined
·
34 Posts
Discussion Starter · #6 ·
Fellow Duke Owners - I need your help:

Bike has been in the shop for 3 weeks, they finally got to it and stated they couldn't replicate the problem. This is total nonsense. Even when I dropped it off, I showed them the leak that was ACTIVELY leaking.

Tech advised it does not leak and kept reiterating this to me. I asked him to change the hose and clamp, but said KTM wont pay since theirs no leak (gaslighting).

Now, I have a KTM with a full warranty and a shop who clearly does not want to take on the work. They are so swamped it seems they rather get rid of my bike. Other shops in the LA area are also seemingly full.

What is my recourse here? Thoughts on how to proceed?

Thanks
 

·
Registered
Joined
·
93 Posts
Fellow Duke Owners - I need your help:

Bike has been in the shop for 3 weeks, they finally got to it and stated they couldn't replicate the problem. This is total nonsense. Even when I dropped it off, I showed them the leak that was ACTIVELY leaking.

Tech advised it does not leak and kept reiterating this to me. I asked him to change the hose and clamp, but said KTM wont pay since theirs no leak (gaslighting).

Now, I have a KTM with a full warranty and a shop who clearly does not want to take on the work. They are so swamped it seems they rather get rid of my bike. Other shops in the LA area are also seemingly full.

What is my recourse here? Thoughts on how to proceed?

Thanks
Complain to KTM. It is not rocket science and a known issue. The leak, if there is one, will generally only occur when the thermostat closes i.e after about half an hour after you have stopped riding the bike. This is because when the coolant cools and the thermostat closes, it builds up pressure in the hoses and thermostat housing. The solution is to tighten the clamps and, if this does not stop the leak, the radiator hose and the thermostat housing where the hose clamps to, must be replaced.
 

·
Registered
Joined
·
34 Posts
Discussion Starter · #8 ·
Complain to KTM. It is not rocket science and a known issue. The leak, if there is one, will generally only occur when the thermostat closes i.e after about half an hour after you have stopped riding the bike. This is because when the coolant cools and the thermostat closes, it builds up pressure in the hoses and thermostat housing. The solution is to tighten the clamps and, if this does not stop the leak, the radiator hose and the thermostat housing where the hose clamps to, must be replaced.
Thanks Paul. FYI - went there last night. They checked me out insisting there is no leak no issue whatsoever. I knew it would keep leaking so I ran it outside for 5 minutes until it leaked and showed it to them. They pulled it in and all the techs and the KTM warranty guy saw the leak. Apparently, its coming from the hose itself (apparently the threads and it is leaking at the end).

So, since they saw it they ordered the hose and clamps with no ETA. I'm anticipating another 1 to 2 weeks given the holidays, which puts me at at least 5 weeks for a simple leak smh. I kept my cool (a new me!) but it was extremely aggravating that it took me 5 minutes to show them, and they had it for 3 weeks for nothing.

I'm still contemplating contacting KTM but that may just be an exercise in futility unless others think not. Finally, they didn't pull the hose/drain the fluid at all so I won't know if there are other issues (known issue you described).

Accepting any more input. Thanks again for the help.
 

·
Registered
'19 790Duke, '20 RC 390
Joined
·
14 Posts
The dealer here also did not see the leak. It really leaked after running, but mostly when it sat cooling down. I insisted and was satisfied when they took it in and replaced the pump housing. The housing went from an oval (what were KTM thinking???) to round and thus fixed the issue. I also have Samco hoses. This took about 2 months to get the housing, to getting installed. I might have got it back a bit sooner but awaiting the clutch switch. I wanted it done at the same time, but in the end, I wanted to ride my 790...love it!
 

·
Super Moderator
Joined
·
1,516 Posts
I know this is an old thread and this is probably, all sorted out already. For the sake of someone reading this for the first time., i would just say that most of the coolant leaks on this bike were reported as loose hose clamps. A 5 minute "repair". Just tightening the relevant clamp bolts. Some more serious thermostat housing issues, as mentioned above, but that not the majority.

Lots of different threads on this. I would not worry too much and start by looking at the hose clamps. Might be a very simple thing.
 
  • Like
Reactions: razteo

·
Registered
Joined
·
93 Posts
I know this is an old thread and this is probably, all sorted out already. For the sake of someone reading this for the first time., i would just say that most of the coolant leaks on this bike were reported as loose hose clamps. a 5 minute "repair". Just tightening the relevant clamp bolts. Some more serious thermostat housing issues, as mentioned above, but that not the majority.

Lots of different threads on this. I would not worry too much and start by looking at the hose clamps. Might be a very simple thing.
Spot on but using a screw driver to tighten a hose clamp is beyond the skill set of most of the key board warriors on the Facebook 790/890 forum😀
 

·
Super Moderator
Joined
·
1,516 Posts
...using a screw driver to tighten a hose clamp is beyond the skill set of most of the key board warriors on the Facebook 790/890 forum😀
You can use a small socket, then.
 
1 - 12 of 12 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top