KTM 790 Duke Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hi all.

So a couple of months ago i picked up my 790 from the KTM dealership. The bike was a demo model with 8000km on the clock, apparently it did a trip around Austria and was ridden around the Nurburgring before coming to South Africa where i bought it. I had a few of the minor issues ive seen on these forums, the oil leak from the seals and a radiator fluid leak, all which were attended to promptly under warranty. So 2 days ago on my way to work about 500m from my place the bike died with a cringe worthy grinding noise. Was in low rpm just cruising and all warmed up (i let my bikes warm up properly before i touch any throttle) today 2 days later i have word from the dealer that there is damage to the cam shaft and counter balance apparently due to the special coating that has worn off. Has anybody heard of this or experienced this before? a warranty claim is underway and new parts are on order and im looking at 18 days till repair. The dealership does not offer extended warranty and this would be devastating if it was out of warranty and i would get invoiced for it. Should i be concerned about the integrity of the motor going forward?

I have only put 3000km ontop of the 8k since i bought it.
 

·
a d m i n .
Joined
·
151,000 Posts
Hi all.

So a couple of months ago i picked up my 790 from the KTM dealership. The bike was a demo model with 8000km on the clock, apparently it did a trip around Austria and was ridden around the Nurburgring before coming to South Africa where i bought it. I had a few of the minor issues ive seen on these forums, the oil leak from the seals and a radiator fluid leak, all which were attended to promptly under warranty. So 2 days ago on my way to work about 500m from my place the bike died with a cringe worthy grinding noise. Was in low rpm just cruising and all warmed up (i let my bikes warm up properly before i touch any throttle) today 2 days later i have word from the dealer that there is damage to the cam shaft and counter balance apparently due to the special coating that has worn off. Has anybody heard of this or experienced this before? a warranty claim is underway and new parts are on order and im looking at 18 days till repair. The dealership does not offer extended warranty and this would be devastating if it was out of warranty and i would get invoiced for it. Should i be concerned about the integrity of the motor going forward?

I have only put 3000km ontop of the 8k since i bought it.
How did this all work out for you, Josh?
 
1 - 2 of 2 Posts
Top