KTM 790 Duke Forum banner

21 - 34 of 34 Posts

Registered
Joined
19 Posts
Discussion Starter #21
Good advice, thank you 馃檪
I'm wondering if a total system reset is possible, in case kinks were existing which didn't necessarily show up. Or a reload or something.
Might be worth asking...
 

Registered
790 Duke 2020
Joined
76 Posts
Its worth your referring to other forum posts if you haven't already done so, like :-


That was one of the reasons why I thought you might have a conflict with the QS and using the clutch at the same time. Mine was noticeably sweeter after its first service, my only niggle being the jerky slow running. But I have never had the stalling that you suffer from. :unsure:
 
  • Like
Reactions: Essie

Registered
Joined
19 Posts
Discussion Starter #24
Went for a bit of explorin' this morning. A lovely ride and a safe encounter with a wedge-tail made for a great outing.

QS off, rain mode on. And yep. He did it again.
So we dropped in on the dealer on the way back to discuss the possibility of a reset and, failing that, an ECU replacement. Without hesitation, a yes to the first request; and a "we'll be on your side" should the need to run it by KTM for the second one arise.
Booked in for Friday 馃檪

Oh and apart from the cutout, I really did manage to stall as well today 鈽
 

Attachments

Registered
790 Duke 2020
Joined
76 Posts
馃憤 Excellent. Constructive progress. Good news. Now that you have tried all combinations and scenarios it will not only give the dealer something to resolve but also encourage them to being on your side, in case special warranty authorisation is needed from KTM. Well done. Looking forward to your next update.
 
  • Like
Reactions: Essie

Registered
Joined
19 Posts
Discussion Starter #26
Just when I was feeling optimistic, I find out that the shop won't be doing the reset... it has to be sent to KTM HO in Melbourne. And may take two weeks. WTF?
Just as well we also have the 390 so I don't have to cage it to work, I guess.
 

Registered
Joined
19 Posts
Discussion Starter #28
Dropped the bike in Thursday after work in preparation for the ECU extraction and despatch.
When we got there, we were told of emails between them and KTM HO regarding our problem.

Firstly, it may not be necessary to send my ECU to Melbourne after all. Apparently it might be possible to do that remotely. No promises however, but slightly heartening all the same.

Secondly, HO had apparently already sent injectors for the jobbie by express post (this was last Thursday, remember), since QLD had none in stock, and this set was supposed to have been the last one in the country, and were on backorder. Lucky me.
Now, as is everywhere else on the planet at present, postal services are a bit hit & miss. Having said that however, things have improved a lot in general, with all express post items we've sent and received doing so within 3 days, working or otherwise.
Plugs also organised for the job.

I'd also discovered a coolant leak last week, so that job was logged as well.

So, again feeling a wee smidge optimistic, we happily left him in their care, hoping for a solution by midweek. I'd also asked to be CCd on the email stream (it was read out to us from their computer). A definite NO on that one, but it was worth asking.

Well, midweek has come and gone with no word, and another almost-week without my wheels.
My partner rang them this arvo to be advised of a no-show of the injectors, and a possible delay into next week. How would they know? Do they have a privilege portal to the national postal system we dumb peasants don't know about? Sure, the mail is out of their hands, but really? That's quite a prediction, which causes a slight doubt of the tense in which said injectors were actually sent. I did wonder at the time if my little bike was special enough to be the recipient of the last injectors in the land. Yeah, I'm getting a tad stabby.
No news re the coolant leak either.
I have to say at this point that it's getting pretty annoying, finding out about quite long delays at the last minute, especially when it's us making the phonecalls or dropping in for updates.
Especially considering we're looking at a 3rd whole week without my beautiful bike out of 8 weeks of ownership :rolleyes:
Anyway, we wait some more. Can only hope for a good outcome at this stage.
 

Registered
2020 790 Duke
Joined
62 Posts
Essie welcome to the club mate. I picked up my new 2020 790 about 3 weeks ago.

It was love at first ride. I now have 750 miles on the clock and it just keeps running stronger and stronger.

So sorry to hear about your trouble with the bike. Hopefully you will find a remedy soon.

Where abouts do you live down under?

Cheers.
 

Registered
Joined
19 Posts
Discussion Starter #34
Got my bike back this arvo.
On Monday The injectors and plugs arrived, so apparently a remote check on the ECU was done via Sydney. No issues found. Still in the dark there. No job sheet was done which seemed strange, regardless of whether I or KTM paid for it. I think I'll be asking for some record of it, just to have info of the bike's history. Ditto the coolant leak. Clamps were just tightened.

So, I rode off, taking the long way home via the highway. The only problem was the engine missing a wee bit in heavy traffic at 4 grand in 3rd, which seemed to sort itself out after a few ks. New injectors bedding in, perhaps?

Anyway, we will see. Was really good to be back on 2 wheels.
 
21 - 34 of 34 Posts
Top