KTM 790 Duke Forum banner

1 - 20 of 23 Posts

·
Registered
Joined
·
49 Posts
Discussion Starter #1 (Edited)
Hi, I got the bike back from it's first service and on getting the bike back in the garage I noticed that there is no track mode in the settings, only the three normal modes. Should it have been enabled as part of the first service, and if this is missing what other settings will not be enabled such as supermoto mode etc?

Also, should the revs on the LCD change colour and you go up the rev range, or did it just change to red when you went above 6000 rpm when running in?

On to the quickshifter, I never really used it when I was running the bike in, but on trying it today the bike made what I can only describe as a brief 'lunge' when on full bore upshifts, and to be honest I couldnt really feel any auto blipping on the downshifts. Am I missing something or am I just not shifting correctly? This is the first bike I've owned with a quickshifter and I wouldn't describe the shifts as smooth or seamless :(

Also for the cost of the first service I didnt even get a list of what work was carried out, it wasnt even cleaned (although Im not really bothered about that as I prefer to clean it myself). When ever Ive had cars serviced I've always been given a checklist of what work was carried out and any remedial work undertaken.
 

·
Registered
Joined
·
52 Posts
Hi John. I agree that you should get it fixed under warranty. Four modes should always be available. I find the quick shifter useful but it’s only really smooth when you’re accelerating or decelerating. Mine’s quite notchy if l use it while just pootling about
 

·
Registered
Joined
·
49 Posts
Discussion Starter #5
Cheers guys, I take back that I said I didnt get a checklist, it had been slipped into the clear plastic pouch on the warranty book :eek:
 

·
Super-Member
Joined
·
606 Posts
How many miles/KM are you at? Mine didn't open up the track mode till I went over 660 miles. It did however show that track was there. Same with the shift light.
 

·
Registered
Joined
·
49 Posts
Discussion Starter #7 (Edited)
Hi Chic, 651 miles. Track mode has never shown up. Other owners have been saying it should be there from day one (but not whether or not it was adjustable or fully enabled), but I've never had the option. So I'm guessing I'm missing modes such as wheelie control, launch control, ABS settings, super-moto mode etc. If I've never had Track showing up from day one, whether I've been able to adjust it or not, that it's a fault. Shift light settings are there.

How many miles/KM are you at? Mine didn't open up the track mode till I went over 660 miles. It did however show that track was there. Same with the shift light.
 

·
Super-Member
Joined
·
606 Posts
Hi Chic, 651 miles. Track mode has never shown up. Other owners have been saying it should be there from day one (but not whether or not it was adjustable or fully enabled), but I've never had the option. So I'm guessing I'm missing modes such as wheelie control, launch control, ABS settings, super-moto mode etc. If I've never had Track showing up from day one, whether I've been able to adjust it or not, that it's a fault. Shift light settings are there.
If I remember correctly, track was showing up and was able to be selected, but yes, no control over any of the adjustable functions. I believe the ABS setting was able to be toggled, but the rest of the selections (wheelie, launch supermoto) were not. If track isn't showing up, I would absolutely make a call and take it in. Maybe they loaded up the wrong system!
 

·
Super-Member
Joined
·
606 Posts
You might consider hitting the 660/1000km and see if that changes anything, but I would schedule the appointment now and go for a 10 mile ride!
 

·
Registered
Joined
·
49 Posts
Discussion Starter #11
This is Scotland we're talking about, our summer lasts 2 days and our winter the rest of the time :crying:

John - get out there and ride the ruddy thing - That few miles the bores are barely scrubbed and the gearbox is a looooooooooooooooooooooooooooooooooong way from being run in. I'd want at least 2000 miles on mine before getting near Track mode.
 

·
Registered
Joined
·
27 Posts
The Track mode and all the features other than Launch Control should be there from Day 1. The quick shifter can be re-calibrated by the dealer, mine didn't work well at all initially, after the re-calibration its been perfect up and down. The changing colour of the rev counter is the shift light warning, it can be set via the menu system, Its set to 6000 revs from the factory.
 

·
Registered
Joined
·
49 Posts
Discussion Starter #19
Scotland and NZ, so similar in scenery and much more Dave, I should have made the move years ago, sadly I'm getting on a bit now, looking forward to NOT working so probably not much of an asset to NZ ;)
 

·
Registered
Joined
·
415 Posts
Scotland and NZ, so similar in scenery and much more Dave, I should have made the move years ago, sadly I'm getting on a bit now, looking forward to NOT working so probably not much of an asset to NZ ;)
Hey we may meet in the Rugby WC, but that Japan team is very good. Good luck for your team:wink: Oh PS my wife Ancestry is Scottish, and her great grandmother is related to Trumps grandmother:sad: Not proud, nothing to celebrate there.
 
1 - 20 of 23 Posts
Top