Low Oil Pressure Light - 2018 KTM 790 Duke Forum
 4Likes
Reply
Thread Tools
post #1 of 18 (permalink) Old 06-29-2019, 03:36 PM Thread Starter
Junior Member
 
Join Date: Jun 2019
Posts: 7
Low Oil Pressure Light

Hey guys, just joined and wanted to post my issue so I can share the results once I get it all worked out.
I had my first service done and now I have about 4,600 miles on my 790 Duke. Today my low oil pressure light kept flickering on and off. After a few miles it stayed on so I pulled over. Didn't see anything immediately wrong. Hoped back on the bike and last few miles home the low pressure oil warning came on and stayed on.
So im scheduled to drop the bike off Wednesday July 3rd. Hopefully I'll get some answers after the holiday weekend. Just thought I'd add the issue and results on here for everyone to know.
J D likes this.
Tjomas Leal is offline  
post #2 of 18 (permalink) Old 06-29-2019, 05:27 PM
J D

Eye In The Sky

 
J D's Avatar
 
Join Date: Mar 2019
Location: New York
Posts: 156
Bummer! Hopefully just a loose wire/bad sensor.

Forum Admin. Life goes by faster than a summer vacation.
J D is online now  
post #3 of 18 (permalink) Old 07-04-2019, 01:46 PM
Junior Member
 
Join Date: Jul 2019
Posts: 1
Hi - my new bike has it too - any update on your situation?
jeffm007 is offline  
post #4 of 18 (permalink) Old 07-05-2019, 04:05 AM
Junior Member
 
Join Date: Jun 2019
Location: Stafford, UK
Posts: 5
Make that 3! My 320 mile bike has been back at the dealer with no oil pressure and a coolant leak for the last 2 weeks, still awaiting an outcome
Mike991 is offline  
post #5 of 18 (permalink) Old 07-05-2019, 03:42 PM
J D

Eye In The Sky

 
J D's Avatar
 
Join Date: Mar 2019
Location: New York
Posts: 156
Quote:
Originally Posted by Mike991 View Post
Make that 3! My 320 mile bike has been back at the dealer with no oil pressure and a coolant leak for the last 2 weeks, still awaiting an outcome
Greeting Mike! Is yours and '18 or 19?
Do you know where the coolant leak location might be? (As there is a somewhat 'common' issue with this for many).

I'm sorry to hear about your no oil pressure bit. Hope that gets resolved for you. Please keep us in the loop.

Forum Admin. Life goes by faster than a summer vacation.
J D is online now  
post #6 of 18 (permalink) Old 07-08-2019, 06:58 AM
Junior Member
 
Join Date: Jun 2019
Location: Stafford, UK
Posts: 5
Many thanks J.D

Mine is a '19 spec bike, the low oil pressure was apparently caused by the filter, this was changed and apparently all is now ok, no mention of why it caused the problem, something I want investigated and an assurance no top end wear has occurred.

The leak was from the top radiator hose and was leaking from within the wall of the hose, kind of in between the layers, so it would seem a manufacturing problem, as opposed to the seating of the hose. The bike is still with the dealer as apparently there is a 2 week lead on the hose.

Got to admit I got a bit pi**ed with the dealer and after a bit of searching found the email address of KTM Austria's MD, filled him in and then all **** broke loose at KTM UK and the dealer and now they seem to be on the case!

Got a loaner at long last, which in my opinion should have been offered straight away, without me having to kick off!
J D likes this.
Mike991 is offline  
post #7 of 18 (permalink) Old 07-08-2019, 08:21 AM
Senior Member
 
Join Date: Sep 2018
Location: Carmarthenshire. Wales. UK
Posts: 186
Good on you Mike, however like you said the dealer should’nt need a big prod from KTM to do their job properly.
J D likes this.
Bugz is offline  
post #8 of 18 (permalink) Old 07-18-2019, 06:52 PM Thread Starter
Junior Member
 
Join Date: Jun 2019
Posts: 7
Update. The dealer found the bike was less than a 1/4th of a court low on oil. So they topped it off and the light went away. They tried to charge me for it but I convinced them that wouldn't be in there best interest. Anyways, yesterday the low oil pressure light came back on. They ordered a new switch and I guess we're gonna try that but I'll show them this thread and mention the filter being an issue for some.
I just want the annoying light gone! I can't see any of my **** gauges cause that low oil pressure warning keeps kicking on and off!
Tjomas Leal is offline  
post #9 of 18 (permalink) Old 08-23-2019, 01:46 PM Thread Starter
Junior Member
 
Join Date: Jun 2019
Posts: 7
Another update. Light still comes on after replacing the switch. No pattern or obviously reason why. Bike is back with the dealer now. They are trouble shooting with KTM on the phone. Will update once I have answers in case anyone else ever experiences this problem.
J D likes this.
Tjomas Leal is offline  
post #10 of 18 (permalink) Old 08-23-2019, 02:19 PM
Moderator
 
Chic's Avatar
 
Join Date: Jan 2019
Location: MD, USA
Posts: 408
Garage
Sorry to hear about this. Hopefully they figure it out. That is super annoying.

Keep the rubber side down!

R.I.P:
RT180
YZ125
R1
Chic is online now  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
Shift Light adjustments Iceblue 790 Duke Engine And Technical Discussion 8 06-28-2019 02:07 PM
Indicator light problem Mister 790 Duke KTM 790 Duke Issues And Problems 0 06-19-2019 01:37 AM
Light TC c82jjul 790 Duke Engine And Technical Discussion 3 11-02-2018 08:35 AM
Maxxis tyres at lower temperatures Mitch KTM 790 Duke General Discussion 17 10-01-2018 11:07 AM
Tyre Pressure owl 790 Duke Wheels And Tires 3 08-28-2018 04:59 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome